Moves Help

Was Moves affected by the “Heartbleed” OpenSSL vulnerability?

A significant vulnerability in OpenSSL software library was publicized on April 7th, 2014. OpenSSL is a common software package and Moves servers were using this software.

As soon as we learned about this so called “Heartbleed” vulnerability, we did the following:

  • All Moves servers were updated to the latest fixed version of OpenSSL within 24 hours
  • Moves’ public SSL certificates were re-keyed

To change your Moves password, sign in at https://accounts.moves-app.com or change the password in the app.